Hello Everyone,
I am in the process of redoing our switch configuration to support our new VOIP solution as well as increase our IP count based on computing type. Would like to hear from all of you to see if I this is an efficient way of setting this all up.
Things to look out for:
1. Does my broadcast traffic hit the correct VLAN and ultimately DHCP?
2. Are my VOIP policies and classes sound?
3. Anything else you can think of! :) I have included one port that is setup for VOIP, and our current legacy port configuration.
!Current Configuration:
!System Description "PowerConnect 6248, 3.3.13.1, VxWorks 6.5"
!System Software Version 3.3.13.1
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 3,10,20,30,40,100,200,300
vlan routing 10 1
vlan routing 30 2
vlan routing 40 3
vlan routing 100 4
vlan routing 200 5
vlan routing 300 6
vlan routing 20 7
exit
hostname "abcCORESW01"
clock timezone -8 minutes 0
stack
member 1 2
member 2 2
member 3 2
exit
switch 1 priority 12
switch 2 priority 11
switch 3 priority 10
ip address 10.0.1.222 255.255.255.0
ip default-gateway 10.0.1.1
ip address vlan 3
ip domain-name abce.net
ip name-server 10.0.1.80
ip name-server 10.0.1.81
class-map match-all class_voip ipv4
match protocol udp
exit
class-map match-all class_ef ipv4
!match ip dscp 46(ef)
match ip dscp 46
exit
policy-map pol_voip in
class class_ef
assign-queue 4
exit
class class_voip
assign-queue 4
mark ip-dscp 46
exit
exit
ip routing
interface vlan 3
name "Legacy VLAN"
exit
interface vlan 10
name "abcWS-Workstations"
routing
ip address 10.0.10.222 255.255.255.0
ip helper-address 10.0.1.81
exit
interface vlan 20
name "abcS-Servers"
routing
ip address 10.0.20.222 255.255.255.0
exit
interface vlan 30
name "abcS-IT Servers"
routing
ip address 10.0.30.222 255.255.255.0
exit
interface vlan 40
name "abcP-Printers"
routing
ip address 10.0.40.222 255.255.255.0
exit
interface vlan 100
name "abcV-VoIP"
routing
ip address 10.0.100.222 255.255.255.0
ip helper-address 10.0.1.81 dhcp
exit
interface vlan 200
name "abc WIFI-Team"
routing
ip address 172.16.1.222 255.255.255.0
ip helper-address 10.0.1.81
exit
interface vlan 300
name "abc WIFI-Guest"
ip address 192.168.1.222 255.255.255.0
exit
username "switchadm" password xx level 15 encrypted
voice vlan
line ssh
password xx encrypted
exit
ip ssh server
cos-queue strict 4
!
!
!
!
!
interface ethernet 1/g39
spanning-tree portfast
switchport access vlan 3
exit
!
interface ethernet 1/g40
service-policy in pol_voip
classofservice trust ip-dscp
description "D40-V"
spanning-tree portfast
switchport mode general
switchport general pvid 10
switchport general allowed vlan add 10,20
switchport general allowed vlan add 100 tagged
switchport general allowed vlan remove 1
lldp med
voice vlan 100
exit
!
interface port-channel 1
description "Port Channel to iSCSI Switches"
switchport access vlan 3
exit
!
interface port-channel 2
description "VM Network for ESX01"
switchport mode general
switchport general allowed vlan add 3,20 tagged
exit
!
interface port-channel 3
description "VM Network for ESX02"
switchport mode general
switchport general allowed vlan add 3,20 tagged
exit
!
interface port-channel 4
description "ESX03 VM Network POrt Channel"
switchport mode general
switchport general allowed vlan add 3,20 tagged
exit
snmp-server community abc-admin rw
enable password xx encrypted
exit